ぶっとびねっと WordPress 簡単インストール後のエラー対応

ぶっとびねっとは管理画面から WordPress / phpBB3 簡単インストール できる。
ただし、バージョンは 2.7.1
しかも、そのままインストールしただけだと deprecated エラーを出しまくる。

これは、サーバのPHPのバージョンを 5.3.x に上がったため。
PHP5.3 では、新たに duprecated エラーが追加されたのに対して
簡単インストールのインストール元にエラー対策を加えていないため。
# こんなことだとこの無料ホームページスペース大丈夫なの?と思うよね。
# まあ無料だからしかたがないけれど。

この deprecated エラーに対応するには
1、wp_load.php と wp_settings.php の error_reporting() に” & ~E_DEPRECATED” を追記する。
これで deprecated エラーは表示されなくなる。

2、加えてこのサーバはタイムゾーンの設定がされていないので、
wp-config.php の先頭の辺りに

と追記してやる。

これで一通りは動くようになります。

動作確認サイトはこちら 負荷耐性が低いので解約しました。


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です